filters
State:
Show
City:
Show
Product:
Show
Alfa Romeo - Worse customer service ever
Alfa Romeo - Worse customer service ever
Alfa Romeo - Worse customer service ever
Car recalled and full of water. Electrical system gone haywire. Car in shop 2 of the 6 mos I’ve owned it. Speakers crackling, wipers failed, windows not going down, gas gauge not accurate, hatch opened twice while driving the car, nav system shut down totally while...
Read more
Company wrote 0 public responses to the review from Aug 10.
2.0
#1326803
Reply to reviews
Used drive assist he was helpful and diagnosed the issue as turbo related garage my car was taken to absolutely shocking no customer care or feedback I was promised a hire car day and a half later still no hire car everyone is blaming everyone else its a joke I was...
Read more
Company wrote 0 public responses to the review from Aug 04, 2016.
Evesham, England
I liked
  • Car
I didn't like
  • Customer service
#894438
Reply to reviews
Alfa Romeo are threatening a customer with bankruptcy proceedings when her installment proposal to repay Alfa’s legal fees in the matter of a failed Mito turbo was rejected. Anita Jackson from Yorkshire, UK bought a new Alfa Romeo Mito in March 2011 but after...
Read more
Company wrote 0 private or public responses to the review from Apr 12, 2015.
1.6
Darlington, England
I didn't like
  • Customer service attitude
  • Warranty
  • Car reliability
#621127
Reply to reviews
Show

Alfa Romeo - Regular oil change 05/04/10

I took my 05 pt cruiser in for a regular oil change & their 2 guys shook my engine 2x that I saw & was told my auto needed motor mounts ALL LIES that would cost $600.00, it only had 56,000 miles, when I got home I called Jason Pulliam the manager & reported this ever since then it has been real hard to get the car in gear, it finally snapped the shift cable 07/30/10 assembly WHAT A RIP OFF it cost me $294.77 total $120.00 for labor & $115.00 for parts, $50.00 towing & $9.77 for tax
Company wrote 0 public responses to the review from Aug 09, 2010.
#193151
Reply to reviews

I perchused my 2003 alfa romeo 166 from the dealer by jan 2005 so the car was uesed by the dealer only with actual 6,000 KM only, manifacture warranty started from September 2005 tow years till Septembet 2007, As i meentioned according the warranty still valid i found...
Read more
Company wrote 0 private or public responses to the review from Jul 23, 2007.
#93000
Reply to reviews
Take note all Alpha Romeo 147 owners on the peril of your life  or at least your bank balance have your timing belt checked and changed. I had taken ownership of an Alpha Romeo 147 01 reg. 3 weeks prior to the timing belt going 5 weeks ago. The car is now!!...
Read more
Company wrote 0 public responses to the review from Apr 24, 2007.
#72537
Reply to reviews